Author Topic: Password seems to break after restart  (Read 4848 times)

Savod

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Password seems to break after restart
« on: May 14, 2012, 01:18:11 AM »
Hello,

First, thanks for the great piece of software that I'm using for years now!

Recently I have a problem:
The password seems to break when the program is restarted.

Everytime I try to do a backup after starting JavaSMFBackup (manually or via autostart) I get the following Exception:
smfbackup.http.SMFException: Login failed (no redirect received to the forum's admin page).
at smfbackup.http.SMFConnection.doBackup(SMFConnection.java:209)
at smfbackup.http.SMFConnection.doJob(SMFConnection.java:500)
at smfbackup.run.Manageable.run(Manageable.java:29)


When I reenter the password, it works again until the next start.

I'm using JavaSMFBackup 1.4.0 under Windows 7 x64 and SMF 2.0.2.
The Version i used previously worked perfectly, I think the problem occurred since I upgraded, but not quite sure.

Thanks

viulian

  • Administrator
  • Newbie
  • *****
  • Posts: 38
  • Karma: +1/-0
    • View Profile
Re: Password seems to break after restart
« Reply #1 on: May 14, 2012, 07:14:59 AM »
Hello,

The only thing I can think off to cause this behavior is that the settings file is read-only and it contains an old password now. The scenario is like this:
a) you defined your forums and so on, put passwords.
b) at a later moment you activated UAC (or something happened, and the settings file is not writable anymore by the app to update password or other forum values)
c) you changed your admin password, but the app can't update the new settings
d) now you have to type it everytime.

Seems a bit strange but ... who knows ?

You have two options:
a) if what I said sounds like what would happen, then please restore rights (or run as administrator).
b) if not, maybe you can try to start it from a command prompt and see if there are exceptions when starting up. Maybe the settings file got corrupted somehow in time and password is not usable anymore.


Savod

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Password seems to break after restart
« Reply #2 on: May 14, 2012, 01:06:04 PM »
Thanks for your quick response!

I checked it twice: the settings file is not read-only, it changes everytime I alter the settings/password.
I'm always running as an Admin, the UAC pops up at every start.

The cmd does not show up errors, but that brought me to an idea: is there a way to start JavaSMFBackup with the password as an parameter, maybe then it would work?

viulian

  • Administrator
  • Newbie
  • *****
  • Posts: 38
  • Karma: +1/-0
    • View Profile
Re: Password seems to break after restart
« Reply #3 on: June 01, 2012, 07:09:27 AM »
Not yet ...

I'm still thinking what could cause this issue ... Can you please try to disable UAC temporarily and then check if it still works ?